Tuesday, November 1, 2011

How to configure EIGRP OSPF Redistribution



How to configure EIGRP OSPF Redistribution:
 
Step 1: Configure IP and Routing of all routers (Lab topology and Running configuration below)

Step 2:  Check out Metric of interfaces using command # show ip interface
R2#show interfaces s0/0/0
Bandwidth=1544 Kbit
Delay=20000/10=2000 > delay 20000 / delay always divided by 10 = 2000
Reliability=255
Load= 1
MTU=1500 bytes

R3#show interfaces f0/0
Bandwidth=100000 Kbit
Delay=100/10=10   > delay 20000 / delay always divided by 10 = 10
Reliability=255
Load=1
MTU=1500 bytes

Step 3:

R2 Router Configuration:
R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 100 metric-type 1 subnets OR
R2(config-router)#redistribute eigrp 100 subnets

R2(config)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500


R3 Router Configuration:
R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 metric-type 1 subnets OR
R3(config-router)#redistribute eigrp 100 subnets

R3(config)#router eigrp 100
R3(config-router)#redistribute ospf 1 metric 100000 10 255 1 1500

Topology:



Running Configuration of all Routers:

Router R1:
hostname R1
!
interface Serial0/0/1
 ip address 192.168.1.1 255.255.255.0
 clock rate 64000
!
router eigrp 100
 network 192.168.1.0
 no auto-summary
!

Router R2:
hostname R2
!
interface Serial0/0/0
 ip address 192.168.3.2 255.255.255.0
!
interface Serial0/0/1
 ip address 192.168.1.2 255.255.255.0
!
interface Serial0/1/1
 ip address 192.168.2.1 255.255.255.0
 clock rate 64000
!
router eigrp 100
 redistribute ospf 1 metric 1544 2000 255 1 1500
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 metric-type 1 subnets
 network 192.168.3.0 0.0.0.255 area 24
!

Router R3:
hostname R3
!
interface FastEthernet0/0
 ip address 192.168.4.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1/1
 ip address 192.168.2.2 255.255.255.0
!
router eigrp 100
 redistribute ospf 1 metric 100000 10 255 1 1500
 network 192.168.2.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 metric-type 1 subnets
 network 192.168.4.0 0.0.0.255 area 34
!

Router R4:

hostname R4
!
interface Loopback1
 ip address 172.16.100.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 192.168.3.1 255.255.255.0
 clock rate 64000
!
router ospf 1
 log-adjacency-changes
 network 172.16.100.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 24
 network 192.168.4.0 0.0.0.255 area 34
!

No comments:

Post a Comment