Showing posts with label DHCP. Show all posts
Showing posts with label DHCP. Show all posts

Sunday, March 11, 2012

How to Configuring IOS DHCP Clients

Task 1: Configure the hostnames on routers R1 and Sw1 as illustrated in the topology.
Task 2: Configure VLAN 100 on Sw1 and name it DHCP_VLAN. Assign port Fa0/2 and Fa0/3 to this VLAN. Enable the ports to automatically transition to the Spanning Tree Forwarding state.
Task 3: Assuming the DHCP server is correctly configured, configure R1 F0/0 to receive IP addressing via DHCP. Verify that R1 has received automatic configuration information via DHCP



DHCP Server Config
 


Running Config of R1:
R1#show running-config
Building configuration...
Current configuration : 438 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
line con 0
line vty 0 4
 login
!
end

Running Config of SW1:
sw1#show running-config
Building configuration...
Current configuration : 1735 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname sw1
!
interface FastEthernet0/1
 switchport access vlan 50
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 50
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan 50
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/4
 spanning-tree portfast
!
interface FastEthernet0/24
 spanning-tree portfast
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
end

Thursday, June 9, 2011

DHCP Configuration in Router

DHCP Configuration in Router:

If you want to configure DHCP in your VLAN network, so flow those steps as your requirement.

Router>enable
Router#configure terminal

Router(config)#ip dhcp pool wireless   >> Create a dhcp pool, name wireless
Router(dhcp-config)#network 192.168.130.0 255.255.255.0 >> mention which network participate
Router(dhcp-config)#default-router 192.168.130.1 >> Getway of this network
Router(dhcp-config)#dns-server 200.200.200.2       >> if you have DNS address

Router(config)#ip dhcp excluded-address 192.168.130.2  >> single IP address fix, like printer, server or any purpose
Router(config)#ip dhcp excluded-address 192.168.130.3 192.168.130.10 >> Range of IP address (low IP to high IP),  as your requirement.