Showing posts with label Frame Relay. Show all posts
Showing posts with label Frame Relay. Show all posts

Wednesday, September 26, 2012

How to configure a Route as Frame Relay Switch



Here I am going to configure about how a router act as frame relay switch. One important thing is that Frame-Relay switch must be configured as DCE. (The Frame-Relay switch must be DCE. In GNS3 on both sites serial interface is DCE, whatever that need to configure clock rate. Clock rate depend on cable type you have. Check out about DCE or DTE by typing ##show controller interface s0/1 command)
Topology of network:

Frame-Relay Network Topology:

Step 1: Turn on Frame-Relay PVC switching capable feature on this route.

FrameRelay(config)#frame-relay switching >> Global Config mode

Step 2: Configure Serial interface to provide Frame-Relay switching
FrameRelay(config)#interface serial 0/0
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000  >> For DCE
FrameRelay(config-if)#frame-relay intf-type dce  >> Configure a FR DCE
FrameRelay(config-if)#no frame-relay inverse-arp >> to disable inverse-arp

Step 3: Now configure Frame-Relay router, it’s configure under the interface.
FrameRelay(config)#interface serial 0/0 >> under this interface
FrameRelay(config-if)#frame-relay route 102 interface serial 0/1 201
FrameRelay(config-if)#frame-relay route 103 interface serial 0/2 301

What the command does? # frame-relay route 103(the incoming DLCI into s0/0) interface serial 0/1(Outgoing interface toward destination DLCI) 301(Destination DLCI)

If we put the “FrameRelay(config-if)#frame-relay intf-type dce command without having “FrameRelay(config)#frame-relay switching” command than we get this message:

Note: From above example configure all interfaces as your requirement.

Step 4: Configure Frame-Relay client router as point-to-point or multipoint
Frame-Relay Point-to-Point example:
HQ(config)#interface serial 0/0
HQ(config-if)#encapsulation frame-relay
HQ(config-if)#exit
HQ(config-if)#no shutdown >> apply after all configuration

Configure Sub Interface -
HQ(config)#interface serial 0/0.102 point-to-point
HQ(config-subif)#ip address 192.168.1.1 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 102 >>
HQ(config-subif)#exit

HQ(config)#interface serial 0/0.103 point-to-point
HQ(config-subif)#ip address 192.168.2.1 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 103 >>
HQ(config-subif)#exit

HQ(config-subif)#frame-relay interface-dlci 103 What the command does? If any time you (Traffic) use this sub interface, make sure that you use this (102 (Local DLCI)) DLCI to go out. No map necessary, no broadcast keyword as like multipoint configuration.

Note: Like same configuration to all routers who act as frame-relay client.

Frame Relay Show or Troubleshoot command:
Frame-Relay Switch (Router):
FrameRelay#show frame-relay pvc
FrameRelay#show frame-relay route  >> to show the Frame-Relay route
FrameRelay#show frame-relay lmi

Frame-Relay Client (Router):
HQ#show frame-relay map
HQ#show frame-relay lmi
HQ#show frame-relay pvc

Ping test:



Show Running Configuration of topology routers:
FrameRelay (Router):
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clockrate 64000
 no dce-terminal-timing-enable
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
 frame-relay route 103 interface Serial0/2 301
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clockrate 64000
 no dce-terminal-timing-enable
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 104 interface Serial0/2 401
 frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clockrate 64000
 no dce-terminal-timing-enable
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103
 frame-relay route 401 interface Serial0/1 104
!
HQ (Router):
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/0.102 point-to-point
 ip address 192.168.1.1 255.255.255.252
 frame-relay interface-dlci 102  
!
interface Serial0/0.103 point-to-point
 ip address 192.168.2.1 255.255.255.252
 frame-relay interface-dlci 103  
!
Branch1 (Router):
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/1.104 point-to-point
 ip address 192.168.3.1 255.255.255.252
 frame-relay interface-dlci 104  
!
interface Serial0/1.201 point-to-point
 ip address 192.168.1.2 255.255.255.252
 frame-relay interface-dlci 201  
!
Branch2 (Router):
!
interface Serial0/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/2.301 point-to-point
 ip address 192.168.2.2 255.255.255.252
 frame-relay interface-dlci 301  
!
interface Serial0/2.401 point-to-point
 ip address 192.168.3.2 255.255.255.252
 frame-relay interface-dlci 401  
!
 



How to configure Frame Relay Point-to-Point




Frame Relay Point-to-Point Topology:
Step 1: Configure Frame Relay Switch on GNS3
 
Step 2: Turn on Frame relay Encapsulation,
HQ(config)#interface serial 1/0
HQ(config-if)#encapsulation frame-relay
HQ(config-if)#exit
HQ(config-if)#no shutdown  >> put this command after create all sub interface.

Create sub interface in HQ router:
HQ(config)#interface serial 1/0.102 point-to-point
HQ(config-subif)#ip address 192.168.1.1 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 102
HQ(config-fr-dlci)#exit

HQ(config)#interface serial 1/0.103 point-to-point
HQ(config-subif)#ip address 192.168.2.1 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 103
HQ(config-fr-dlci)#exit

Note: same configuration for all sub interfaces

Step 3: Configure branches
Branch1(config)#interface serial 1/0
Branch1(config-if)#encapsulation frame-relay
Branch1(config-if)#exit
Branch1(config-if)#no shutdown >> put this command after create all sub interface.

Create sub interface in Branch router
Branch1(config)#interface serial 1/0.201 point-to-point
Branch1(config-subif)#ip address 192.168.1.2 255.255.255.252
Branch1(config-subif)#frame-relay interface-dlci 201
Branch1(config-fr-dlci)#exit

Note: same configuration for all sub interfaces and also other branches 
Frame Relay Troubleshoot Command:
HQ#show frame-relay map
HQ#show frame-relay lmi
HQ#show frame-relay pvc


Here i troubleshoot about (#show frame-relay map) Deleted status of frame-relay MAP:
I going to establish new connection between Branch1(105) and Branch2(501), after complete configuration the status of "#show frame-relay map" command (Same output on both router)
this may happened, cause the DLCI does not on frame-relay switch or configured. so added the DLCI into frame-relay switch.

Frame Relay have slower update process. so wait for some time and see output of command
#show frame-relay map: Everything will be fine...

Running Configuration of all Routers:

Router HQ:
!
interface Loopback0
 ip address 200.200.200.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.102 point-to-point
 ip address 192.168.1.1 255.255.255.252
 frame-relay interface-dlci 102  
!
interface Serial1/0.103 point-to-point
 ip address 192.168.2.1 255.255.255.252
 frame-relay interface-dlci 103  
!
interface Serial1/0.104 point-to-point
 ip address 192.168.3.1 255.255.255.252
 frame-relay interface-dlci 104  
!
 
Router Branch1:
!
interface Loopback0
 ip address 172.16.100.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.105 point-to-point
 ip address 192.168.4.1 255.255.255.252
 frame-relay interface-dlci 105  
!
interface Serial1/0.201 point-to-point
 ip address 192.168.1.2 255.255.255.252
 frame-relay interface-dlci 201  
!

Router Branch2:
!
interface Loopback0
 ip address 10.100.200.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.301 point-to-point
 ip address 192.168.2.2 255.255.255.252
 frame-relay interface-dlci 301  
!
interface Serial1/0.501 point-to-point
 ip address 192.168.4.2 255.255.255.252
 frame-relay interface-dlci 501  
!

Router Branch3:
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.401 point-to-point
 ip address 192.168.3.2 255.255.255.252
 frame-relay interface-dlci 401  
!

Tuesday, September 25, 2012

How to configure Frame Relay Multipoint interface




Frame Relay Multipoint Topology:
 Step 1: Configure Frame Relay Switch on GNS3

Step 2: Configure HQ router
HQ(config)#interface s1/0
HQ(config-if)#encapsulation frame-relay >> turn on frame relay encapsulation
HQ(config-if)#ip address 192.168.100.1 255.255.255.0  >> specify ip  address
HQ(config-if)#frame-relay map ip 192.168.100.2 102 broadcast  >> Branch1
HQ(config-if)#frame-relay map ip 192.168.100.3 103 broadcast >> Branch2
HQ(config-if)#frame-relay map ip 192.168.100.4 104 broadcast >> Branch3
 
Or may create Sub interface to configure Frame-Relay:
HQ(config)#interface s1/0.1 multipoint
HQ(config-subif)#encapsulation frame-relay >> turn on frame relay encapsulation
HQ(config-subif)#ip address 192.168.100.1 255.255.255.0  >> specify ip  address
HQ(config-subif)#frame-relay map ip 192.168.100.2 102 broadcast  >> Branch1
HQ(config-subif)#frame-relay map ip 192.168.100.3 103 broadcast >> Branch2
HQ(config-subif)#frame-relay map ip 192.168.100.4 104 broadcast >> Branch3

Note: The “Broadcast” keyword only use in Multipoint Frame Relay map

Step 3: Configure Branch1
Branch1(config)#interface s1/0
Branch1(config-if)#encapsulation frame-relay
Branch1(config-if)#ip address 192.168.100.2 255.255.255.0
Branch1(config-if)#frame-relay map ip 192.168.100.1 201 broadcast >> for HQ
Branch1(config-if)#frame-relay map ip 192.168.100.3 201 broadcast >> for Branch2
Branch1(config-if)#frame-relay map ip 192.168.100.4 201 broadcast >> for Branch3

Note: all Branch3, Branch4 Configuration is same as Branch1

Ping status:
 
Frame Relay Troubleshoot Command:
HQ#show frame-relay map

HQ#show frame-relay lmi

HQ#show frame-relay pvc

 
Running Configuration of all Routers:

Router HQ:
 !
interface Serial1/0
 ip address 192.168.100.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.2 102 broadcast
 frame-relay map ip 192.168.100.3 103 broadcast
 frame-relay map ip 192.168.100.4 104 broadcast
!
interface Serial1/0.1 multipoint
!

Router Branch1:
!
interface Serial1/0
 ip address 192.168.100.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.1 201 broadcast
 frame-relay map ip 192.168.100.3 201 broadcast
 frame-relay map ip 192.168.100.4 201 broadcast
!

Router Branch2:
!
interface Serial1/0
 ip address 192.168.100.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.1 301 broadcast
 frame-relay map ip 192.168.100.2 301 broadcast
 frame-relay map ip 192.168.100.4 301 broadcast
!

Router Branch3:
!
interface Serial1/0
 ip address 192.168.100.4 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.1 401 broadcast
 frame-relay map ip 192.168.100.2 401 broadcast
 frame-relay map ip 192.168.100.3 401 broadcast
!