Showing posts with label EtherChannel. Show all posts
Showing posts with label EtherChannel. Show all posts

Sunday, July 31, 2011

How to configure Ether Channel

How to configure Ether Channel

Ether Channel:
An Ether Channel is a way of combining several physical links between switches into one logical connection. Normally, Spanning Tree Blocks redundant links, But Ether Channels get around that and enable load balancing across those links. Traffic is balanced between the channel links on the basis of such things as source or destination MAC address or IP address.

Ether Channel types:

1. Cisco Proprietary Port Aggregation Protocol (PAgP): Is an Inter-Switch Link (ISL) standard (Cisco proprietary encapsulation method). Dynamically negotiates the formation of channel. There are three modes:

  • On – The port channels without using PagP negotiation. The port on the other side must also be set to On.
  • Auto – Responds to PagP messages but does not initiate them. Port channels if the port on the other end is set to Desirable. This is default mode of PagP.
  • Desirable – Port actively negotiates channeling status with the interface on the other end of the link. Port channels if the other side is Auto or Desirable.

2. Link Aggregation Control Protocol (LACP):  Is an IEEE Standard protocol, IEEE 802.1q (dot1q encapsulation method). LACP are three modes:

  • On – The port channels without using LACP negotiation. The port on the other side must also be set to On.
  • Active – Port actively negotiations channeling with the port on the other end of the link. A channel forms if the other side is Passive or Active.
  • Passive – Responds to xcfLACP message but dose not initiate them. A channel forms only if the other end is set to Active.
 If you want to use LACP, specify it under the interface and put the interface in either active or passive mode:
(config-if)# channel-protocol lacp
(config-if) channel-group number mode {active | passive}

Example of configuration of PAgP and LACP:

Step 1:  Configure interface as Logical Group.

Start IF PAgP:
{ Please must be shutdown port (Exe. f0/7-8) both site before configure; (Example: DLS1(Layer 3 SW) to ALS1(Layer 2 SW)):

Layer 3 SW (DLS1):
DLS1#configure terminal
DLS1(config)#interface range fastEthernet 0/7-8
DLS1(config-if-range)#channel-group 2 mode desirable   >> create Pagp group
DLS1(config-if-range)#exit

DLS1(config)#interface port-channel 2    >> this is logical group interface
DLS1(config-if)#switchport trunk encapsulation dot1q  >> if layer 3 SW, you must need to encapsulate by using dot1q;
DLS1(config-if)#switchport mode trunk

Layer 2 SW (ALS1):
ALS1#configure terminal
ALS1(config)#interface range fastEthernet 0/7-8
ALS1(config-if-range)#channel-group 2 mode desirable   >> create Pagp group
ALS1(config-if-range)#exit

ALS1(config)#interface port-channel 2   >> this is logical group interface
ALS1(config-if)#switchport mode trunk
ALS1(config-if)#exit   
 }End PAgP
 
Start If LACP:
{ Please must be shutdown port (Exe. f0/9-10) both site before configure; (Example: ALS1(Layer 2 SW) to ALS2(Layer 2 SW)):

Layer 2 SW (ALS1):
ALS1#configure terminal
ALS1(config)#interface range fastEthernet 0/9-10
ALS1(config-if-range)#channel-group 1 mode active
ALS1(config-if-range)#interface port-channel 1
ALS1(config-if)#switchport mode trunk
ALS1(config-if)#exit

Layer 2 SW (ALS2):
ALS2#configure terminal
ALS2(config)#interface range fastEthernet 0/9-10
ALS2(config-if-range)#channel-group 1 mode active
ALS2(config-if-range)#interface port-channel 1
ALS2(config-if)#switchport mode trunk
ALS2(config-if)#exit
} End LACP

Note: This above configuration is example of how to configure PAgP and LACP. Please configure as your network requirement.

Another Note: In this example I configured Inter VLAN using Layer 3 Switch. Please Check How to configure Inter VLAN on Layer 3 Switch.

Step 2:
The Ether Channel load-balancing method is configured at global configuration mode:
Syntax: (config)# port-channel load-balance type

ALS1#configure terminal
ALS1(config)#port-channel load-balance dst-ip  >> configure to all Switch

Note: Next time I post detail.

Step 3: Show command of Ether Channel:
ALS1#show etherchannel summary

 ALS1#show interfaces trunk
 ALS1#show etherchannel load-balance


Ether Channel Topology