Thursday, November 3, 2011

How to configure OSPF Virtual Link with IPV6

Step 1: Enable IPv6 In Global Mode

R1#configure terminal
R1(config)#ipv6 cef
R1(config)#ipv6 unicast-routing

Step 2: Assing IPv6 Address

R1#configure terminal
R1(config)#interface f0/0
R1(config-if)#ipv6 address a:a:a:a::1/64

Step 3: IPv6 Support OSPFv3 (Config)

R1(config)#ipv6 router ospf 1
R1(config-rtr)#router-id 1.1.1.1 (must
configured IPv4 for DR BDR election)

Ospf apply in Interface
R1(config)#interface f0/0
R1(config-if)#ipv6 ospf 1 area 0

Step 4: Create Virtual Link For Area 0 to Area 45

R2(config)#ipv6 router ospf 1
R2(config-rtr)#area 11 virtual-link 3.3.3.3

R3(config)#ipv6 router ospf 1
R3(config-rtr)#area 11 virtual-link 2.2.2.2

Some Show Command:
R1#show ipv6 route
R1#show ipv6 ospf
R1#show ipv6 interface brief
 
Topology Lab:
 


Running Configuration of all routers:
  
R1#sho running-config
!
hostname R1
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ipv6 unicast-routing
ipv6 cef
!
no crypto isakmp ccm
!
interface Loopback0
 no ip address
 ipv6 address FEC0:1::1/128
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address A:A:A:A::1/64
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
control-plane
!
end

R1#show ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   A:A:A:A::/64 [0/0]
     via ::, FastEthernet0/0
L   A:A:A:A::1/128 [0/0]
     via ::, FastEthernet0/0
OI  B:B:B:B::/64 [110/65]
     via FE80::CE01:1FF:FEA4:0, FastEthernet0/0
OI  C:C:C:C::/64 [110/66]
     via FE80::CE01:1FF:FEA4:0, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
LC  FEC0:1::1/128 [0/0]
     via ::, Loopback0
OI  FEC0:2::2/128 [110/1]
     via FE80::CE01:1FF:FEA4:0, FastEthernet0/0
OI  FEC0:3::3/128 [110/65]
     via FE80::CE01:1FF:FEA4:0, FastEthernet0/0
OI  FEC0:4::4/128 [110/66]
     via FE80::CE01:1FF:FEA4:0, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0
 
R2#show running-config
hostname R2
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
no crypto isakmp ccm
!
interface Loopback0
 no ip address
 ipv6 address FEC0:2::2/128
 ipv6 ospf 1 area 11
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address A:A:A:A::2/64
 ipv6 ospf 1 area 0
!
interface Serial1/0
 no ip address
 ipv6 address B:B:B:B::1/64
 ipv6 ospf 1 area 11
 serial restart-delay 0
 no dce-terminal-timing-enable
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 11 virtual-link 3.3.3.3
!
control-plane
!
end
 
R3#show running-config
 hostname R3
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
no crypto isakmp ccm
!
interface Loopback0
 no ip address
 ipv6 address FEC0:3::3/128
 ipv6 ospf 1 area 11
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address C:C:C:C::1/64
 ipv6 ospf 1 area 45
!
interface Serial1/0
 no ip address
 ipv6 address B:B:B:B::2/64
 ipv6 ospf 1 area 11
 serial restart-delay 0
 no dce-terminal-timing-enable
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 11 virtual-link 2.2.2.2
!
control-plane
!
end

R4#show running-config
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
no crypto isakmp ccm
!
interface Loopback0
 no ip address
 ipv6 address FEC0:4::4/128
 ipv6 ospf 1 area 45
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address C:C:C:C::2/64
 ipv6 ospf 1 area 45
!
ipv6 router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
!
control-plane
!
end

1 comment:

  1. great, it really helps someone like me who is not a very computer literate person.

    ReplyDelete