Wednesday, September 26, 2012

How to configure Frame Relay Point-to-Point




Frame Relay Point-to-Point Topology:
Step 1: Configure Frame Relay Switch on GNS3
 
Step 2: Turn on Frame relay Encapsulation,
HQ(config)#interface serial 1/0
HQ(config-if)#encapsulation frame-relay
HQ(config-if)#exit
HQ(config-if)#no shutdown  >> put this command after create all sub interface.

Create sub interface in HQ router:
HQ(config)#interface serial 1/0.102 point-to-point
HQ(config-subif)#ip address 192.168.1.1 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 102
HQ(config-fr-dlci)#exit

HQ(config)#interface serial 1/0.103 point-to-point
HQ(config-subif)#ip address 192.168.2.1 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 103
HQ(config-fr-dlci)#exit

Note: same configuration for all sub interfaces

Step 3: Configure branches
Branch1(config)#interface serial 1/0
Branch1(config-if)#encapsulation frame-relay
Branch1(config-if)#exit
Branch1(config-if)#no shutdown >> put this command after create all sub interface.

Create sub interface in Branch router
Branch1(config)#interface serial 1/0.201 point-to-point
Branch1(config-subif)#ip address 192.168.1.2 255.255.255.252
Branch1(config-subif)#frame-relay interface-dlci 201
Branch1(config-fr-dlci)#exit

Note: same configuration for all sub interfaces and also other branches 
Frame Relay Troubleshoot Command:
HQ#show frame-relay map
HQ#show frame-relay lmi
HQ#show frame-relay pvc


Here i troubleshoot about (#show frame-relay map) Deleted status of frame-relay MAP:
I going to establish new connection between Branch1(105) and Branch2(501), after complete configuration the status of "#show frame-relay map" command (Same output on both router)
this may happened, cause the DLCI does not on frame-relay switch or configured. so added the DLCI into frame-relay switch.

Frame Relay have slower update process. so wait for some time and see output of command
#show frame-relay map: Everything will be fine...

Running Configuration of all Routers:

Router HQ:
!
interface Loopback0
 ip address 200.200.200.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.102 point-to-point
 ip address 192.168.1.1 255.255.255.252
 frame-relay interface-dlci 102  
!
interface Serial1/0.103 point-to-point
 ip address 192.168.2.1 255.255.255.252
 frame-relay interface-dlci 103  
!
interface Serial1/0.104 point-to-point
 ip address 192.168.3.1 255.255.255.252
 frame-relay interface-dlci 104  
!
 
Router Branch1:
!
interface Loopback0
 ip address 172.16.100.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.105 point-to-point
 ip address 192.168.4.1 255.255.255.252
 frame-relay interface-dlci 105  
!
interface Serial1/0.201 point-to-point
 ip address 192.168.1.2 255.255.255.252
 frame-relay interface-dlci 201  
!

Router Branch2:
!
interface Loopback0
 ip address 10.100.200.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.301 point-to-point
 ip address 192.168.2.2 255.255.255.252
 frame-relay interface-dlci 301  
!
interface Serial1/0.501 point-to-point
 ip address 192.168.4.2 255.255.255.252
 frame-relay interface-dlci 501  
!

Router Branch3:
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/0.401 point-to-point
 ip address 192.168.3.2 255.255.255.252
 frame-relay interface-dlci 401  
!

Tuesday, September 25, 2012

How to configure Frame Relay Multipoint interface




Frame Relay Multipoint Topology:
 Step 1: Configure Frame Relay Switch on GNS3

Step 2: Configure HQ router
HQ(config)#interface s1/0
HQ(config-if)#encapsulation frame-relay >> turn on frame relay encapsulation
HQ(config-if)#ip address 192.168.100.1 255.255.255.0  >> specify ip  address
HQ(config-if)#frame-relay map ip 192.168.100.2 102 broadcast  >> Branch1
HQ(config-if)#frame-relay map ip 192.168.100.3 103 broadcast >> Branch2
HQ(config-if)#frame-relay map ip 192.168.100.4 104 broadcast >> Branch3
 
Or may create Sub interface to configure Frame-Relay:
HQ(config)#interface s1/0.1 multipoint
HQ(config-subif)#encapsulation frame-relay >> turn on frame relay encapsulation
HQ(config-subif)#ip address 192.168.100.1 255.255.255.0  >> specify ip  address
HQ(config-subif)#frame-relay map ip 192.168.100.2 102 broadcast  >> Branch1
HQ(config-subif)#frame-relay map ip 192.168.100.3 103 broadcast >> Branch2
HQ(config-subif)#frame-relay map ip 192.168.100.4 104 broadcast >> Branch3

Note: The “Broadcast” keyword only use in Multipoint Frame Relay map

Step 3: Configure Branch1
Branch1(config)#interface s1/0
Branch1(config-if)#encapsulation frame-relay
Branch1(config-if)#ip address 192.168.100.2 255.255.255.0
Branch1(config-if)#frame-relay map ip 192.168.100.1 201 broadcast >> for HQ
Branch1(config-if)#frame-relay map ip 192.168.100.3 201 broadcast >> for Branch2
Branch1(config-if)#frame-relay map ip 192.168.100.4 201 broadcast >> for Branch3

Note: all Branch3, Branch4 Configuration is same as Branch1

Ping status:
 
Frame Relay Troubleshoot Command:
HQ#show frame-relay map

HQ#show frame-relay lmi

HQ#show frame-relay pvc

 
Running Configuration of all Routers:

Router HQ:
 !
interface Serial1/0
 ip address 192.168.100.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.2 102 broadcast
 frame-relay map ip 192.168.100.3 103 broadcast
 frame-relay map ip 192.168.100.4 104 broadcast
!
interface Serial1/0.1 multipoint
!

Router Branch1:
!
interface Serial1/0
 ip address 192.168.100.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.1 201 broadcast
 frame-relay map ip 192.168.100.3 201 broadcast
 frame-relay map ip 192.168.100.4 201 broadcast
!

Router Branch2:
!
interface Serial1/0
 ip address 192.168.100.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.1 301 broadcast
 frame-relay map ip 192.168.100.2 301 broadcast
 frame-relay map ip 192.168.100.4 301 broadcast
!

Router Branch3:
!
interface Serial1/0
 ip address 192.168.100.4 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no dce-terminal-timing-enable
 frame-relay map ip 192.168.100.1 401 broadcast
 frame-relay map ip 192.168.100.2 401 broadcast
 frame-relay map ip 192.168.100.3 401 broadcast
!

What is Frame Relay and how is work


Evaluation of Layer 2 Technologies:
  1. X.25
  2. Frame Relay
  3. ATM
  4. MPLS (New)
The Foundation concepts of all technologies are same. The all about are connected through shared bandwidth cloud. The connections are defined by PVC (Privet Virtual Circuit). Each one of them has bandwidth limitation, know as CIR (Committed Information Rate).

Frame Relay: It’s a Standardized WAN technology. Is a second generation technology in packet switching world. That Specifies the Physical and logical link layer.  In the scenario, frame relay service provider sells you cheaper connection (Shared bandwidth), cause they don’t have dedicated bandwidth to you. Example - Frame relay provider has total bandwidth 2Gbps bandwidth and they sell like 3.5Gbps to their customer to meet their customer requirement. Cause they monitoring, testing their network to determine that not everybody going to use all their bandwidth at the same time.  (this example like as bank)

Frame Relay Terminology: Frame Relay is not like Ethernet or even leased line, so how this connection work to using some terminology.
  • CIR (Committed Information Rate) – The minimum bandwidth the service provider provides you, like 500Kbps. Some time always your network use (Bosted) bandwidth above CIR, the service provider always monitor their network, so they sagest you to get paid and also upgrade your CIR.
  • LAR (Local Access Rate) – LAR is how fast the circuit can go. This is one of the big different with Ethernet. Example – in LAN environment you plug-in cable, that cable speed like 100Mbps, if the computer can send 100Mbps data than the cable can handle it.Now in Frame Relay, the link speed like 10Mbps, and your CIR is 512Kbps. So you should be configure the router with 512Kbps as agreement, So here is the different Logical and Physical speed mismatch.
  • LMI (Local Management Interface) – LMI is a language you speak between your router to Frame Relay switch. It is a signaling protocol. The service provider send you statistic to use the LMI, like link status, quality of transmission, about dropping packet and also send about DLCI information
  • DLCI (Data Link Connection Identifier) – on frame relay network DLCI take place instead of MAC Address. DLCIs are locally significant (Means you can duplicate your DLCI number, same DLCI placed in both site, and also in different link, but you can’t add same DLCI in single link where the link act as multiple access). Example - In frame relay network you send data to DLCI (200) as your destination, the service provider take the data through the cloud and comes on DLCI (300) other site. 
  • PVC (Privet Virtual Circuit) – Logical connection between one point to another point in frame relay network. Every single one of PVC has specific CIR. So you pay for each PVC.

Type of Frame Relay Network: 
  • Hub-And-Spoke:  Much cheap/inexpensive, one act as hub and all other may spoke, if Hub goes down than all spoke may down. Spoke communicate with other spoke by using hub.   
  • Full Mesh: Much expensive $$. Fully redundant topology. All routers were connected each other. There low possibility of goes down. Exe – Voip, MPLS
  • Partial Mesh: Some part using hub-and-spoke and other may redundant.


Interface Configuration in Frame Relay:
About “Split Horizon” - Is a loop prevention technique, “Never sent an update back in the same direction that receives from the same interface.”
  • Multipoint – Same subnet use for all routers. Multiple DLCI is mapped to single interface. Split Horizon problem (Disable on Physical Interface, Enabled on Sub-Interface)
  • Point to Point – Different subnets is needed to connect to each connection. Point to Point sub-interface created for each peer. No problem with split horizon.

How to Configuration FrameRelay:

Multipoint Frame-Relay configuration Command: (How to Config Multipoint Example)
Router(config)#interface s1/0
Router (config-if)#encapsulation frame-relay >> turn on frame relay encapsulation
Router (config-if)#ip address 192.168.100.1 255.255.255.0  >> specify ip  address
Router (config-if)#frame-relay map ip 192.168.100.2 102 broadcast >> for multipoint interface.

Or may create Sub interface to configure Frame-Relay:
Router (config)#interface s1/0.1 multipoint
Router (config-subif)#encapsulation frame-relay >> turn on frame relay encapsulation
Router HQ(config-subif)#ip address 192.168.100.1 255.255.255.0  >> specify ip  address
Router (config-subif)#frame-relay map ip 192.168.100.2 102 broadcast >> Frame Relay map for multipoint interface.

What the “broadcast” does?
Router(config-subif)#frame-relay map ip 192.168.100.2 201 broadcast 
The broadcast is initiate broadcast to another site router through frame relay. RIP, OSPF, EIGRP either use broadcast or multicast messages, by default the frame relay routers deny those broadcast messages from being sent through the link. So if you do not put the broadcast keyword with the command, you routing protocol wouldn’t work through frame relay network.

Point –to-Point Frame-Relay configuration Command: (Point-to-Point Configure Example) the point to point frame relay mode is only configured on sub interfaces.  

Step 1: Turn on Frame-relay on Physical Interface
Router(config)#interface serial 1/0
Router (config-if)#encapsulation frame-relay
Router (config-if)#exit
Router (config-if)#no shutdown  >> put this command after create all sub interface.

Step 2: Create point to point Sub Interfaces under the Physical Interfaces to support point to point frame relay.

Router (config)#interface serial 1/0.102 point-to-point
Router (config-subif)#ip address 192.168.1.1 255.255.255.252
Router (config-subif)#frame-relay interface-dlci 102
Router (config-fr-dlci)#exit

#frame-relay interface-dlci 102 >> what the command does?
If any time you (Traffic) use this sub interface, make sure that you use this (102 (Local DLCI)) DLCI to go out. No map necessary, no broadcast keyword as like multipoint configuration.

Frame Relay Troubleshoot command:
Router#show frame-relay lmi  >> check (Num status megs send rcvd number)
Router#sho frame-relay pvc  >> Check out PVC status.
Router#show frame-relay map
You check detail about frame relay status. Like your remote IP address, your local DLCI, “Static” (Configured by administrator as static), “Broadcast” may active, “Cisco” (Other site must be cisco device), and status active/inactive/deleted.
  • Active – both site correctly setup and operational
  • Inactive – your site is configured but other site not
  • Deleted – you may put an DLCI “345” but the frame relay switch don’t know about this DLCI or does not exist , so this status will be shown as Deleted.

Some Note and Tips:
Router(config-if)##frame-relay lmi-type cisco/ansi/q9eea >> Frame Relay encapsulation for older router. Now on new router able to auto detect LMI using #encapsulation frame-relay

Router(config-subif)#frame-relay map ip 192.168.100.3 301 ietf  broadcast >> if you communicate with non cisco router on other site (Industry Standard). By default is cisco proprietary. 



Wednesday, June 6, 2012

Link state Routing Protocol


Link state Routing Protocol Feature:
  • Use multicast to build neighbor relationship rather than broadcast
  • After initial routing tables exchange, routers send small, event-based updates
 LS Routing Protocol Advantages:
  • Much faster to converge
  • Force you to design your network design correctly
  • No routing loops issue
 LS Routing Protocol Disadvantage:
  • Demand on router resources
  • Technical complexity
  • Requires actual network design

Distance Vector Routing Protocol


Distance Vector Routing Protocol Feature: 
  •  Distance Vector (DV) Routing Protocols exchange entire routing table at specific (30 Second) intervals
  •  Distance Vector (DV) Routing Protocol is easy to configure
  •  Distance Vector (DV) Protocol has looping issues
 Distance Vector Routing Protocol Loop Prevention mechanism:
 Cisco routers have 5 loop prevention mechanisms to prevent loop issue 
  •  Maximum hope count – with rip max 16 hops
  •  Router Poisoning – with rip, manually set 16 hops to kill route.
  • Triggered Update – trigger update send about any change
  •  Split Horizon – do not sent update, back in the same direction you receive them on network set are being advertise
  •  Hold Down Timer – set hold down timer, Cisco default hold down time is 180 seconds